Przejdź to tekstu

Ankieta: Możliwość instalacji kilku wersji Iceweasela równocześnie?

Mike Hommey, deweloper Debiana, poprosił o komentarze na temat wprowadzenia możliwości równoległej instalacji dwóch (lub więcej) wersji przeglądarki Iceweasel (opartej — z niewielkimi modyfikacjami — na kodzie źródłowym Firefoksa).

Hommey pyta czy istnieje duże zapotrzebowanie na możliwość instalacji więcej niż jednej wersji Iceweasela (np. 3.0 i 3.5) równocześnie. Jeśli tak — rozważy wprowadzenie takiej sposobności.

Komentarze w tej sprawie (po angielsku) należy umieszczać pod odpowiednim wpisem na jego blogu.

Dodany przez azhag, 16 wrz 2009 o 08:28

OSnews Wykop Blip Flaker Kciuk Śledzik Facebook Identi.ca Twitter del.icio.us Google Bookmarks


Komentarze (RSS):

  1. rlk120, 2009-09-16 14:37 [#]:

    A czemu miałoby służyć posiadanie dwóch wersji Iceweasela ?


  2. azhag, 2009-09-16 16:39 [#]:

    > A czemu miałoby służyć posiadanie
    > dwóch wersji Iceweasela ?

    Przede wszystkim nie można na to patrzeć przez pryzmat „dwa naraz”. Wprowadzenie dwóch pakietów — nazwijmy je roboczo — iceweasel-30 i iceweasel-35, umożliwi nie tylko instalację dwóch wersji jednocześnie (może być przydatne np. dla webmasterów), ale też łatwy wybór którą z dwóch wersji zainstalować (obecnie trzeba kombinować: albo 3.0, albo użyć experimentall — co nie na każdej gałęzi i nie zawsze jest możliwe). Powody dla których ktoś może chcieć inną niż „obowiązującą” wersję mogą być różne: jeden chce mieć funkcje dostępne w nowej, inny woli zostać na starszej np. z powodu niekomatybilności wtyczek.


    Notabene podobna sytuacja jest w innych pakietach, np. edytor Emacs dostarczany jest w trzech pakietach (pomijając te z kompilacjami z różnymi interfejsami graficznymi): emacs21, emacs22 i emacs23, odpowiednio: gałąź 21.x, 22.x i 23.x. :)
    ____

    Dopisek:
    Hm, komentarz podobnych rozmiarów co nius. ;)


  3. k4misiek, 2009-09-16 23:07 [#]:

    Fajnie byłoby gdyby nie ograniczyli się do iceweasela np. fajnie byłoby mieć wine w wersji stabilnej i rozwojowej do wyboru.


  4. , 2009-09-17 00:11 [#]:

    Jest wine i wine-unstable - dawno się nie zaglądało do repo :) ?


  5. k4misiek, 2009-09-17 00:17 [#]:

    Ach no faktycznie, jeszcze jakiś czas temu tego nie widziałem. Co nie zmienia faktu, że do innych aplikacji też to by się przydało ;P


  6. azhag, 2009-09-17 07:11 [#]:

    Tylko pakiet wine-unstable ma konflikt z wine, nie można ich zainstalować jednocześnie.

    W wolnej chwili będę musiał poprosić opiekuna Wesnotha o możliwość „koinstalacji” 1.6.x i 1.7.x.


  7. marg1, 2009-09-17 12:20 [#]:

    I dobrze, też uważam, że to bez sensu mieć 10 różnych wersji tych samych programów, niech będzie jedna, a dopracowana :)


  8. k4misiek, 2009-09-17 19:21 [#]:

    Ile ludzi tyle zdań.


  9. yantar, 2009-09-18 04:20 [#]:

    Niektóre programy aż się prosi by były dostępne w dwu różnych wersjach. Na prawdę niefajnie jest gdy po upgrade, człowiek potrzebuje skorzystać z programu a tu coś się wykrzaczy. I zamiast robić swoje dłubie nad downgrade. Iceweasel, Gimp i pare innych dość popularnych pakietów by się znalazło.


  10. azhag, 2009-09-18 21:35 [#]:

    Skoro już jesteśmy przy wymienianiu własnych zdań :) — moim zdaniem dobrze by było wprowadzić proponowaną zmianę, ale jeśli wymaga to dużo dodatkowej pracy, która może zostać spożytkowana w lepszy sposób — wtedy nie, to nie jest aż tak wazne.

    Co napisałem Hommeyowi. :)


Dodaj komentarz jako gość lub zaloguj się.


Podpis: